vendredi 14 juillet 2017

Google Won’t Add Support for aptX on the Nexus 5X and Nexus 6P

With Android O, Google added support for more Bluetooth audio codecs such as Sony’s LDAC as well as Qualcomm’s aptX and aptX HD to enable high-quality bluetooth audio streaming on supported devices.

If you’re on an Android O Developer Preview, you can find an option to choose between various Bluetooth audio codecs under Developer Options. However, keep in mind that these codecs may not work on some devices unless the proper encoder libraries are installed. Case in point: it looks like the Nexus 5X and Nexus 6P won’t be able to take advantage of aptX after all.

In case you’re not aware, aptX is a streaming protocol owned by Qualcomm that allows supported devices to stream lossless, low-latency audio to supported Bluetooth-enabled devices. Although the two Nexus devices contain hardware that supports the codec, the Bluetooth audio codec is missing from Developer Options on these devices. The issue first came to light when a Nexus 6P user filed a bug report on the Google Issue Tracker page mentioning that he was unable to get the audio codec working on his device, to which a Google developer replied with the following message:

Status: Won’t Fix (Intended Behavior)

Unfortunately support for aptX and aptX HD are not supported on Nexus 6p and Nexus 5X – only on newer devices.

So there you have it: both the Nexus 5X and Nexus 6P do not officially support aptX and aptX HD, and Google has no plan to add support for them. It’s not like the Nexus 5X and 6P don’t have the necessary hardware to support these codecs; as pointed out by a user in the same thread, the LG G4 also has the same audio chip (Qualcomm WCD9330) as the Nexus 5X and 6P and the G4 does support the codec. It could be that Google is looking to avoid potential licensing fees it would have to pay Qualcomm if it added support for its proprietary codecs on the Nexus 5X and Nexus 6P, however, we will never know the exact reason unless Google officially provides a statement on this matter.

Interestingly enough, since both the Nexus 5X and Nexus 6P already have required hardware to support the audio codec, it’s possible to get it working on these devices. In fact, there is already a Magisk module available for the Nexus 6P that enables support for aptX. Head over to the official thread for more details on enabling aptX on the Nexus 6P.


Source: Google Issue Tracker Via: Android Police



from xda-developers http://ift.tt/2tc5wHo
via IFTTT